• Back to work 15% off
    • 60% off Traffic Cones & Bollards
    • Seton School Safety

    PCI Compliant - Supported Browsers

    Microsoft has discontinued support for Internet Explorer browsers version 10 and lower, which includes security updates to those browsers. Other websites, including third-party payment services, will soon no longer support these versions of Internet Explorer.

    You should upgrade to the latest versions of Chrome, Firefox, Safari and/or Internet Explorer browsers. If you cannot upgrade your Internet Explorer to version 11 or above, we recommend that you try Chrome or Firefox on your platform.

    Supported Browsers

    In order to get the most out of this site, we recommend that you download the latest version of one of the following browser:

    Continuing to use Internet Explore 10, 9 and 8?

    If you continue to browse our website using Internet Explorer browsers 10, 9 and 8, then please follow the instructions below in order to manually enable the security protocols that will allow you to purchase from our website.

    1. On the Internet Explorer main menu, select “Tools” (or the “gear” icon in the upper right corner), and select “Internet Options
    2. In the Internet Options box, select the “Advanced” tab
    3. In the Security category, uncheck “Use SSL 2.0” and “Use SSL 3.0”, check “Use TLS 1.0”, “Use TLS 1.1”, and “Use TLS 1.2” (if available)
    4. Click “OK
    5. Exit and restart Internet Explorer

    Note: it is important to check consecutive versions. Not selecting consecutive versions (for example, checking TLS 1.0 and 1.2, but not checking 1.1) could result in connection errors.